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DIGITAL MEDIA WORKSHOP-Flash Animation 

Tonya D. Skinner, Presenter 

http://sites.google.com/site/nce2010skinner/ 

Getting Started 

Depending on the version of Flash you are using, panels will be in different places. For the most part, Flash 8 through CS3 will appear 

mostly the same. When you get to CS4/CS5, the panels are moved around a little bit, namely the Properties panel is not at the 

bottom anymore and the Timeline is not at the top. It takes a little getting used to, but you should be able to adapt to any of those 

versions if you know the basics. You can always check out the variations of screen setups, called Workspaces, under the 

Window>Workspace menu. 

Screenshot from Flash CS3 

 

Screenshot from Flash CS4 
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Decisions, Decisions… 

Before you create a new Flash file (FLA), you need to consider a few things: 

• What size do you want this animation to be?  (can be changed, but objects will not be resized to match if you change your 

mind later)  

• What color do you want the background to be?  (can be changed, but it stays the same for the entire project for all scenes) 

• What frame rate do you want to use? (can be changed at any time) Higher number of frames per second (fps) means what 

is on your timeline will play faster.  

• What version of ActionScript do you want to use? This is not easily changed in newer versions, so it’s a decision you should 

make at the beginning of the process. You can choose ActionScript 2 or 3 and for the novice user, this actually matters 

because certain codes for buttons and actions will not work if they are written in the wrong version (NOTE: Flash 8 uses 

ActionScript 2 by default; CS3 and higher use ActionScript 3 by default) 

Default Properties for Flash 8—12 fps, ActionScript 2 

 

Default Properties for Flash CS5—24 fps, ActionScript 3 

 

Your Turn—Part 1 

1. Create a new Flash file with Actionscript 3, blue background/stage color, 12 frames per second, and a Stage size of 800px 

wide by 600px tall. (NOTE: if you are using Flash 8 or earlier, you will not have AS3 as an option and the code would have to 

be modified later on) 

2. Save as CARD.FLA. 
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Basic Drawing 

Drawing in Flash is much easier than drawing in some other programs. For one, you don’t have to be an artist to get a decent looking 

drawing because you can utilize tools to bend and shape existing shapes into new ones. And, you can easily combine shapes into one 

nice, neat shape. If you are going to manipulate or combine shapes, it’s a good idea to check to be sure “Object Drawing”  is 

turned off (the J button will toggle this on/off).  

Some strange things about drawing and shapes in Flash: 

• Fills (inside color) and Strokes (borders) of shapes are separate pieces. It’s a little hard to get used to. Just know that if you 

decide to pick up a shape and move it around, you have to double click it to select both parts. 

• Overlapped shapes eat each other. Well, sorta. If you put a shape over a shape and then move the top shape, the part that 

was previously hidden will disappear. 

• Touching shapes become one shape if there is no stroke or the stroke dividing the shapes is removed. They will then move 

as one or can be filled in with the Paint Bucket. 

• The Paint Bucket  changes the fill color; the Ink Bottle changes the stroke color.  

Your Turn—Part 2 

3. Select the Oval tool (can press O or in some versions, it hides under the Rectangle tool). 

4. Be sure Object Drawing is turned off ( ). 

5. Select yellow as the Fill color and black as the Stroke (border) color. Click and drag to draw these two ovals as shown. Be 

sure to draw the big one first so the small one is on top.  

   

NOTE: You can also select colors by using the Colors panel, which is available 

through Window>Color (or Color Mixer) 

  

  

  

  

6. It is a good idea to keep drawings and their pieces separate (so you can animate them and such later on). So, unlike we 

have done at this point, which is just “draw stuff” on the Stage, you typically want to make drawings inside a safe, place. 

These safe places are called Symbols in Flash. So, let’s take our current drawing and convert it to a symbol so we can keep 

working on it. Select All (Control+A or you can take the black arrow tool and just draw a box around everything) and then 

click Modify>Convert to Symbol (or press F8).  Name the Symbol bee and set the type to Movie Clip. Then, press OK. 

  

7.  Notice that you now have a blue bounding box around your bee. You can’t edit the bee while the bounding box is around 

it. To edit, we have to get INSIDE the symbol. A symbol has its own Timeline and its own Layers. Double click the symbol OR 

you can locate the symbol in the Library (F11) and bring it up from there. When you double click, you should see the 

following at the top of your screen indicating you are editing the bee--   
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8. Here’s the screen view (this is Flash 8/CS3; if in CS4/5 and not using Classic View, the Timeline may be at the bottom of the 

screen): 

 

As shown above, double click the word Layer 1 and rename that layer beebody. Then, lock the layer so we can’t mess it up 

by pressing the dot under the padlock:  

 

9. Next, press the New Layer button below the bee’s Timeline to add a few more layers. Name them as follows and order 

them as you see here (just click and drag to reorder): 

   

10. Lock all layers except legs. We are going to draw the legs using the Pencil tool. Click on the legs layer, select the Pencil tool, 

and then look for the Options button. If you draw the legs now, they will get all ugly and pointy (try it if you don’t believe 

me…you can undo). So, set the Options for the Pencil to Smooth. 

 Click and hold and set to Smooth 

11. Zoom up close (200% or so) and draw in legs. Be sure the “feet” paths are closed or you will have problems filling them in 

later. Then, fill in with the Paint Bucket. 
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NOTE: If you cannot fill in the foot, you might have a little gap. Just zoom in super close, take your black arrow tool, and 

point to the end of the line where the problem is and drag it. Or, look for the option to close gaps and try a different 

setting—by default, it does not close gaps: 

 

12. Once that’s all done, lock the legs layer. Unlock and select the leftwing layer.  

13. Now we’ll use the Pen  tool to draw. This tool is pretty neat because you just click (think “dot to dots”) where the 

corners will be (Do not click and drag! Click, let go, click, let go, etc.). Be sure to close off the path (you may have to guess or 

you can turn the body of the bee off before you do this part). 

 

14. In the above illustration, notice how the line has a curve. Well, to make it curve, AFTER you draw in the wing, just point to 

that segment. Your mouse will have a little curvy line. Just click and drag that curvy line. Continue to modify the shape to 
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your liking. Fill in the wing with color (doesn’t matter what color for now). 

   

15. Then, lock this layer, unlock the other wing, and draw it using the same process. Alternatively, you can copy the shape and 

paste it if you’d like. Turn the visibility off on the beebody layer if needed. 

16. Now, lock all layers except the face layer. Using shapes of your choice (I used two circles, a circular paintbrush, and a line 

that I curved with the black arrow tool), draw a face. 

       

17. Finally, let’s “dress up” the body by adding some stripes. Lock all layers except beebody. Then, use the Line  tool and 

draw in sets of lines, fill with black (be sure you have no gaps, so zoom up!), and then use the black arrow tool to point at 

segments to curve them: (and, if you want, add a stinger) 

      

18. Lastly, add anything else you want to any of the layers (how about some antenna on the face layer?). Science people might 

want to add a couple more legs. ☺  

 Finally, SAVE!! 
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Gradients 

Gradients are a little confusing in Flash because it’s just hard to find. There is not a button for 

it. To add a gradient as a fill, you just use the Paint Bucket, like all other fills. The exception is 

that you use the Color Mixer to do it and you change the normal setting (SOLID) to a gradient 

type (linear, radial, etc.). 

Gradient have multiple colors that blend into each other. Those colors are referred to as 

“stops” and can be added, deleted, or modified at the bottom of the Color panel. 

Your Turn—Part 3 

19. Remember that we are still working inside the “bee” symbol. At this point, we are 

going to change the wings to a gradient. Usually, bee wings are somewhat 

transparent. So, we’ll use a white to blue gradient to mimic the color of wing vs. sky. 

Lock all layers except the right and left wings. 

20. Click the Paint Bucket tool and then bring up the Color panel (Window>Color). 

21. Change the settings as follows—radial gradient, light blue to white, with alpha of 70% for each stop: 

     

Notice Alpha or A is set to 70%, which sets it to have a little bit of transparency.  

22. If you feel so bold, try out a gradient (yellow to orange or something) for the bee’s body. Just remember that the body 

would not be transparent, so the stops would need to be put back to Alpha of 100%. 

  

23. Now, exit Symbol editing (we’re done with the bee…for now) by clicking the back arrow to return to Scene 1. 

 

24. Save! 
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 Understanding Symbols 

You might recall, way back when we started drawing our bee, that we created him as a movie clip Symbol. There are essentially 

three “symbol types” in Flash—graphic, movie clip, and button. Honestly, I don’t use graphic very often; movie clip does the same 

thing anyway and more. And, if you decide later on to animate a symbol, it has to be a movie clip anyway. Button is used to 

create…buttons. They have a very different timeline. We’ll make a button later on.  

Symbols have what are called Registration Points. They don’t do a whole lot, but if 

you start to transform, add action, or rotate a symbol, you’ll learn exactly what 

that registration point does. When you are editing a symbol, the registration 

point appears as a crosshair. 

If your registration point, like this one, is not in the center, you can go back into 

Symbol editing, select everything (Control+A) and then position your object with 

the point in the center. 

If you are “transforming” a symbol (Free Transform Tool, Q) you will see a white 

dot, called a transformation point. It’s easy to accidentally move that around, but 

again, you typically want to keep that in the center as well. So, just a few minor 

notes to make in your head.  

 

Your Turn—Part 4 

25. Now, the bee is huge, so we will use the Free Transform handles (press Q or choose the 

tool  or ). You will see transformation handles appear around the bee. 

 Now, hold Shift (so you can’t mess up the aspect ratio) and resize it down using a corner 

handle. Note that white circle in the middle—that’s the transformation point. 

26. Switch back to the black arrow tool (Selection tool, or press V) and position the bee in the 

top right corner. 

      

27. Now, name that layer (Layer 1) and call it bee. 

28. To see what this Flash movie looks like so far, you can test it. Just click Control>Test Scene. 

It will appear in its own little window. Not much happening so far, huh? Exit the preview. 

29. Now, just for fun and to illustrate the concept of Symbols, drag more copies of the bee out 

of the Library (F11). Using the Transform tool (Q) resize and rotate  them as you 

please.  
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Why Symbols Rock 

So, you see now that Symbols are reusable content. And, because they are stored in the Library and reusable, they really don’t 

increase file size much. So, that’s a good thing. But, the coolest thing is that Symbols can be edited in one place and all instances of 

that Symbol are updated automatically. So, if I was having a “bad drawing day” I seriously could just make a symbol and call it man 

and then just draw a stick man until I feel like taking time to draw a real dude. Neato! 

Likewise, if you decide to add animation inside a movie clip Symbol, it will apply to all instances. Let’s do it! 

Your Turn—Part 5 

31. So, let’s update this bee! One thing he’s missing (poor thing) is a nose. So, double click on any bee (pick a bee, any bee) and 

you will go into Symbol editing mode. Notice everything else “grays out” a bit and you can see all the “bee layers” on the 

Timeline, so it’s proof you are inside the bee symbol.  

32. Zoom up on the bee’s face (Control and +) and unlock only the face layer. Draw (with any 

tool—I used a pencil) in a nose-like feature. Then, return to the Scene-- . 

33. Zoom out (Control and -) so you can see all the bees. Now, they all have little noses! 

 

 

 Frame-by-Frame Animation and Keyframes 

To do the “fun” stuff in Flash, you have to understand how to animate. And, to animate, you must understand keyframes. 

 First is the blank keyframe. 

A blank keyframe has a hollow dot. It represents a frame on the Timeline that is “ready” to hold something. You 

cannot put objects in frames if they are not blank. If you click on frame 50 and it’s not a blank keyframe and you 

draw something, it will actually show up not in frame 50, but in the first blank keyframe on that layer. And, if that 

layer has no blank keyframes, it won’t draw period. When you create a new layer, it automatically has one blank 

keyframe in frame 1. Pressing F6 in an empty frame creates one of these. 

Next is the keyframe. 

A keyframe has a solid dot. It represents a 

frame that has something in it. Blank 

keyframes turn into these when you put 

something in them. Pressing F6 creates one of 

these if preceded by a frame with content. 

Finally, is the frame span.  

 A frame span represents an area where you are basically telling Flash to just “keep that keyframe” going 

for awhile. If we wanted our bees to stay on the screen for a certain amount of time, we’d insert a frame 

span (Insert>Frame). Pressing F5 inserts a frame to continue the frame span. 

 

You can do animation either on the main Timeline or inside symbols. And, whether you do it one way or the other entirely depends 

on the end goal of your animation.   
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Your Turn—Part 6 

34. We are going to animate the bee’s wings. So, pick a bee or double click the bee in the Library to start editing on the bee’s 

timeline. I like to use the Library copy because it will open bigger. 

35.  Take a look. Right now, we have five layers with five keyframes holding various parts of the bee’s body. Be sure all layers 

are locked except for the leftwing layer. Then, click that layer to select the wing. Press Q or click the Free Transform button. 

  

36. Now, at frame 5 on the leftwing layer, press F6 to insert a keyframe. Why? Well, we want to move the wing at this point so 

that it appears to flap. Notice when we do this that the rest of the bee disappears. That’s because we did not tell those 

layers to “stay put.” 

  See, the legs layer just has empty frames going on… so we see no legs. 

37. To fix that, we need to just insert a regular “stay put” frame on all other layers. So, first click on frame 5 of the legs layer 

and press F5 (frame). There are those silly little legs! 

   Repeat this process for the other layers. 

38. Now, we are going to wiggle that leftwing a little bit to make it appear to move. Rotate it a little bit and maybe “smash” it a 

little bit, too. Just use the transform handles and “make it your own.” Drag the playhead to preview your movement. 

39. Next, unlock rightwing (and lock leftwing). In frame 5, press F6 to insert a keyframe so we can make a change. Then, 

transform the right wing to your liking.  

40. Lock everything back and return to Scene 1, out of symbol editing mode. You will see all those bees hanging out again. 

However, they aren’t flapping their wings, are they? How dare them! 

41. That’s because Movie Clips do not play on the Timeline. The only way to see them is to test the animation. So, click 

Control>Test Movie and take a look. 

42. Pretty nifty, huh? It’s a little troubling since they all match exactly (attack of the clones) but that’s how Symbols work. You 

could go a step further and make them all blink their eyes or wiggle legs, etc.  But, you get the idea. ☺ 
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43. Now, just for grins, take your bottom left bee and flip him so he faces the other way (drag your transform handles beyond 

the boundary or click Modify>Transform>Flip Horizontal). 

 

Tweening 

One of the most powerful features of Flash is the ability to “tween” an object. This simply means that you decide where something 

starts—location and transformation (point A) and where and how it ends (point B) using two keyframes and the built in tweening. 

There are two kinds of tweening—motion and shape tweens. Motion tweens can only be used on symbols. Shape tweens can only 

be used on shapes or “broken apart” objects.  

One big thing to note-- Tween only one object per layer. Remember that Flash considers the stroke and the fill to be separate 

objects. If your path has both, move the stroke and the fill to different layers, and tween them separately but simultaneously. 

Otherwise, crazy things happen. Trust me.  

Your Turn—Part 7 

44. Remember that bee facing the opposite direction? Well, we are going to move him to his own layer so he can be tweened. 

We want him to fly across the screen. So, simply right click him and CUT. 

45. Then, create a new layer, name it bee2, and right click on the Stage and select PASTE IN PLACE. This paste option will put 

him right back where we cut him from. As it is good practice, let’s lock the bee layer. 

46. To make him zoom across the scene, we have to decide the frame span for the movement. As we are using 12 fps for the 

speed, it will take him one second to cross 12 frames. So, 60 frames would be (60 divided by 12) five seconds. Insert a 

keyframe (F6) in frame 60. 

47. Then, click in frame 60 and move him off the stage to the right. 

  

48. If you test the scene right now, it’s all kind of crazy. The other bees disappear, he sits there forever, and then it blinks. We 

must fix this! 

49. First, remember, to make his bee friends “stay up there” we need a frame on there. So, press F5 by frame 60 of the bee 

layer. Now he’s not lonely anymore. 

50. Finally, let’s get him moving gradually by inserting a tween. A few things to note about this: 

Flash 8/CS3�  You will only have one “right click” option for tweening—Create Motion Tween. Use that. 

Flash CS4/CS5� You have two options—Create Motion Tween and Create Classic Tween. Choose the Classic option. 

51. So, to insert a tween, just click anywhere between the two keyframes on the bee2 layer. Frame 20, for example. It doesn’t 

matter. Then, right click and create the appropriate tween. 

You now should see a long arrow line in a shaded purplish area. That means a tween is happening. Control>Test Scene now 

and watch the magic as the bee flies across the Stage. 

 



12 

 

Motion Guides 

Motion Guides can be used in Flash to give your animation a specific path. For example, if you want the bee to buzz around in a 

circle, you can specify this in a motion guide. This is also one area that changed quite a bit from version CS3 to CS4. This tutorial will 

show you both ways just in case you don’t have the newest version. And, you can still use the “old fashioned” way in the new 

versions, but the “new way” is actually much more fabulous.  

Your Turn—Part 8 

52. Let’s take another bee and give him his own layer. Cut your top right bee, create a new layer (bee3) and paste him in place. 

 

Insert a frame at the end of the sequence so he stays on the screen (F5). 

53. Now, this tutorial will take detour. Follow the appropriate steps for your version of Flash: 

a. Flash CS4/CS5: At this point, you will insert a “new” Motion Tween. This will allow you to refine the animation 

specifically to your liking using the Motion Editor. Pick any frame (frame 2 is good) on the bee3 layer, right click, 

and select Create Motion Tween. The line will turn blue. Then, click the Motion Editor tab right next to the 

Timeline tab: 

 

i. if you expand that entire tab, you’ll see Basic motion, Transformation, and Eases. There are tons of 

options in here. And the nice thing is that you don’t have to insert keyframes along the way. It just 

“knows” based on how you move the red playhead line. Very handy. So, move the Playhead to frame 5 

and then reposition the bee: 
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ii. Next, scrub the Playhead to about frame 15 and then repeat. Move the bee. But this time, after you move 

him, point to the line between the points (don’t click it) and notice the “curvy” mouse pointer. Click and 

drag to curve the path: 

 

iii. Finally, drag Playhead to frame 60 and finish your Motion path. I’m going to go crazy on this one and draw 

curves all over the place: 

 

iv. Now, Control>Test Scene. Looks pretty good, but notice how he is 

all “prim and proper” and stays straight the whole time? Let’s fix 

that. 

v. You can set any tween to have the symbol so that it orients itself to 

the path. Go back to the Timeline view and in the Properties panel, 

click Orient to Path (you may need to click on the timeline in the 

blue tweeny area first).  

vi. Test the scene again and cackle in amazement. ☺ SAVE! 
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b. Flash 8/CS3: This version doesn’t have a fancy Motion Editor, so we have to create the path old school. And, it’s 

sometimes problematic. 

i. In this version, you need to end the path with a keyframe. So, at frame 60 on bee3, insert a keyframe (F6) 

so a black dot appears. Then, click on that frame and reposition the bee to his ending point (lower right 

corner). 

ii. Click somewhere between those two keyframes on bee3 and right click>Create Motion Tween. It will 

tween, but not in the way you want (mine just flies straight down). 

iii. To fix that, we need an official Motion Guide. Right click the 

bee3 layer (where the word is) and select Add Motion 

Guide. You’ll see a little guide layer with a line on it.  

iv. Lock the bee3 layer so you don’t mess it up (and all layers, really) except the Guide layer. 

v. Now, drag the Playhead to frame 1 and then use a pencil and draw a path for the bee.  

 

vi. Now, lock the Guide layer and unlock the bee3 layer to position the bee at the ends of the guide. 

vii. Click the Selection tool (black arrow) and be sure your bee is “stuck” to the end of the line in frame 1. He 

should snap to it (if not, check to see if View>Snapping>Snap to Guides is checked). 

viii. Then, click in frame 60 and do the same thing. Be sure he’s lined up with the path (the registration point 

should be at the end of the line). Drag the playhead when you think it’s good to see if he follows the path. 

Hopefully he will. If not, zoom up closer, pull him 

off, and try again. Sometimes it takes a few times 

(which is probably why they changed this in newer 

versions!). 

ix. Finally, click in the Properties panel and check the 

Orient to Path button to make sure he actually 

turns to follow the line. Be sure you are clicked in a 

frame somewhere during the motion tween. 

x. Note the guides do not show on playback. Test the scene again and pat yourself on the back. ☺ SAVE! 
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Bring on the Clipart 

Tired of drawing everything? You can actually import clipart images (referred to by Flash as bitmap images) or really just about any 

other image for use. However, you cannot edit them or do much to them because they are not symbols.  

Clipart is useful for some Flash designers because there is a special option called Trace Bitmap that allows you to take a bitmap 

image and convert it to shapes and lines. When this happens, you can then recolor the object or make changes to it.  

Your Turn—Part 9 

54. In your data files is a file called beehive. To bring this image into Flash, click 

File>Import>Import to Library and browse for the file. It should now be housed in the 

Library (F11). 

55. I’ve found lineart is easiest to work with in Flash. For this beehive, let’s use the Trace 

Bitmap feature, remove the white background, and make the hive an appropriate color. 

So, first, make a new layer, name it beehive, and drag it out. It’s rather large. 

56. Now, click Modify>Bitmap>Trace Bitmap. This “traces” the bitmap and turns it into a 

series of “painted” colors (a vector, actually). You can play around with the settings, but 

the defaults will work with this simple image quite well.  

57. Click on the white background and press delete. Then, use the Paint Bucket and fill in 

the white spots with an appropriate hive color. 

58. Finally, lock all layers except the beehive layer. Then, select the hive (Control+A) and 

convert it to a movie clip symbol called hive (F8). 

59. Reposition the beehive layer to be lower than everything (in the background, 

essentially).  

 

60. And, let’s make the whole thing a little longer before it loops by inserting a frame on all layers in frame 80 (F5). 

61. Save! 

 

Shape Tweens 

I honestly use shape tweens very little. They tend to do strange things. However, they are a feature of Flash and we should 

acknowledge that. So, just know this… you can shape tween anything that is “broken apart” (has that gray speckled selection on it 

when you click on it) and you can break apart anything by pressing Control+B. It doesn’t mean you should, though. Personally, I do 

not use strokes when I use shape tweens because they go crazy. And, it’s easiest to actually manipulate the starting shape and just 

change its position, reshape it using the black or white arrows or transform tools, or change its color. Those things will typically work 

just fine. 
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Your Turn—Part 10 

62. Let’s create an animated cloud to put in the background. Create a new layer, call it 

cloud, and move it to the bottom of the layer stack on the Timeline. Lock all other 

layers. 

63. Now, create a new Symbol—Insert>New Symbol (set to Movie Clip) named cloud. 

Now, to create it using a Shape tween! 

64. Use the Paintbrush set to white and draw a cloud. Then, fill it in with the same 

color using the Paint Bucket.   

65. With a looping shape tween, it’s a good idea to have the starting and ending 

frames be the same. So, insert a keyframe at frame 30 (F6) but make no changes. 

66. Then, insert a keyframe at frame 15. We’ll make the changes here, in the middle. 

We want these to be subtle cloud changes, so it won’t be too extreme. 

67. While on frame 15, use the Selection arrow (black arrow), click off the cloud, and 

then point to the curves. Reposition (use the curvy mouse pointer) parts. Not too 

much. Just a few places. 

68. Now, right click on the Timeline between the first two keyframes and Create 

Shape Tween. Repeat between the last two. You will see shaded green areas on 

the Timeline. (NOTE: Flash 8/CS3 does not have shape tween on the right click menu and must be selected from the 

Properties panel under the Tween option—set to Shape) 

 

69. Return to Scene 1. Drag the cloud out of the Library onto the cloud layer you created. Test Scene. 

 

There you have it. It’s a Shape Tween. Not the greatest thing since sliced bread, but you might come up with neat uses for it 

in creating simple animations, such as web banners. 

70. Save! 
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Don’t Change All My Symbols! 

Remember that we discussed how updating one symbol updates all of them? Well, what if you don’t want to? 

You can “copy” a symbol and disconnect it from the group. To do so, you use the Library. Simply right click a symbol in the Library, 

Duplicate it, and give it a new name. Then, you will have two identical but unrelated symbols that you can make changes to. When 

you double click to edit one, it will not affect the other(s). 

Your Turn—Part 11 

71. In your data files is a file called flower-clipart-01. To bring this image into Flash, click File>Import>Import to Library and 

browse for the file. It should now be housed in the Library (F11). 

72. Create a new movie clip symbol (Insert>New Symbol) and name it orange flower. Drag the flower into this new symbol and 

use Trace Bitmap (Modify>Bitmap>Trace Bitmap). Remove the background like before and erase the text. Then, return to 

the scene. 

73. Create a new layer called flowers. Position near the bottom of the stack, in front of the clouds. Drag two copies of the 

orange flower symbol to the Stage. Flip one horizontally and scale as you desire. 

 

74. Now, let’s create a different colored flower. To do so, in the Library, right click 

orangeflower’s movie clip and select Duplicate. Then, give it the name redflower.  

75. In the Library, double-click the redflower movie clip and use the Paint Bucket to recolor 

the flower as you desire. 

76. Finally, drag a few copies of the red flower out to the flowers layer.  

NOTE: You can “copy” a flower by holding Alt while dragging! 

 Beautiful! Save! 
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Sound! 

What’s some multimedia without sound, right? You can easily import sound files into Flash to use in projects. There are numerous 

ways to do it, and we’ll only cover the “easy” way in this session. However, you can add sound many different (and more 

complicated) ways. Many sound file types are acceptable, though my best luck has been with WAV files. Some MP3 files will not 

work, so it’s important to test your file (just try to import it) before you get too deep into a project.  Like all other objects, you will 

import sound to your Library where it will stay until you drag it in to use it. 

Your Turn—Part 12 

77. Create a new layer called buzz and move it to the top of the stack of layers. Lock all other layers. Then, insert a blank 

keyframe at frame 40. We want to have a sound play for a little bit and then play again so we need two different “starting” 

frames. 

  

78. File>Import>Import to Library and browse for the beebuzz.wav file. It will appear in the Library with a little speaker icon 

next to it so you can tell it is a sound.  

79. Next, click on frame 1 and just drag the sound out onto the Stage. When you let go, you should see a waveform 

representing your sound appear on the Timeline during the duration of the sound. You won’t hear it. NOTE: If you want to 

hear it, click in the waveform and in the Properties panel, set Sync to Stream. 

 

80. Now click in the blank keyframe on 40 and repeat this process. You will now see two waveforms. Save and Test Scene to 

check it out. NOTE: If you change your mind about a sound, you can remove it in the Properties panel: 

  

81. You can also edit sound in Flash, including adding a Fade in/out or removing “dead air” or trimming a clip. Simply click the 

pencil under Sound in the Properties panel and making changes to the Edit Envelope dialog box: 

 

Other effects are also available in the Effect drop down menu. Changes only affect that particular sound in those frames, not 

every instance of the sound in the project. 

NOTE: In Flash 8/CS3, the panel doesn’t have a pencil. Instead, it’s the Edit menu:  
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Scenes 

In Flash, you can create multiple scenes for action. As it is, with what we are creating so far, that first scene is pretty full of stuff. It 

would be distracting to keep going out to frame 100 or 200 or 500 and continue animating. Or, if you wanted to start removing bees, 

you’d insert many keyframes and start deleting things. It would be very confusing. 

So, scenes help with this. To access the Scene panel, where you can add, delete, rename, or reorder scenes, you go to 

Window>Other Panels>Scene. 

Scenes play in the order listed. You can also add special commands (called ActionScript) to make your file NOT go to the next scene 

so that you can allow users to navigate using buttons. But, one thing at a time! 

Your Turn—Part 12 

82. Open the Scenes panel and rename Scene 1 to be crazybees. It’s the same as 

renaming a layer—double click it, type it, and press Enter.  

83. Press the little paper icon in the bottom left corner to add a new scene. Name the 

second scene beehave. 

    

84. We will not reorder these scenes, but you change the order the same way as reordering layers—just click and drag. 

85. Add one final scene to the end and call it replay. Then, close the Scene panel. 

 Notice that in older versions, the plus sign is used to add new scenes. 

86. To change which scene you are working on, look for the clapboard icon and press it.  

Let’s go to the beehave scene next. Select it and Save. 
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Text 

So far, we’ve only use bitmaps or drawn items. But, text is important, too. To insert text, you use the Text Tool (a capital A in older 

versions and a capital T in newer ones). The newer versions have MANY more options for working with text. 

  

The main thing to remember about text is that if you wish to make changes to it, select it (highlight it) first. Also, don’t try to resize 

text by resizing the box; use the size slider button to resize the font.  

The big tall box is the panel for text in CS5; below 

is the panel in Flash 8. Big difference! 
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Your Turn—Part 13 

87. REVIEW: In this new scene, before we get going on adding text, let’s do a few things you should know how to do based on 

the previous lessons. 

88. Rename Layer 1 in the beehave scene to be background. 

89. On this layer, draw the trunk of a tree. Use the Pencil tool to draw it and fill it with brown. I also added a few lines with the 

pencil tool afterward for effect. 

90. Next, import the file daisy-clipart-01 to the Library. Then, create a new movie clip symbol (Insert>New Symbol) called 

daisy, drag the bitmap file into this new symbol, Trace Bitmap (settings will need to be modified a little on this one—try 50 

for color threshold, 5 px for minimum area, tight curve fit, and few corners), and remove the background and text. Return 

to the scene. Drag a few copies of the daisy movie clip out to the background layer. Lock the layer. 

 

91. Now, we’ll have the bee fly in. So, create a new layer named bee. 

Drag the bee out and position off stage at right. Insert a keyframe 

(F6) at frame 30 and position the bee in the center of the tree. 

Insert a Classic Tween (or older versions, Motion Tween) between 

the frames so he flies into place. (if you can’t guess on position, you 

can insert a frame—F5—on the background) 

92. Create a new layer called swatter. Then, lock all other layers. 

93. Create a new movie clip symbol (Insert>New Symbol) called swat. Import the Fly_Swatter.jpg image to the Library, Drag it 

in. Trace Bitmap and remove the extra stuff and white background. Return to the beehave scene. 

94. On the swatter layer, insert a blank keyframe (F6) on frame 30. Drag the swat movie clip onto the stage in this frame. 

Resize/rotate as shown below. 

  

95. Before we go further, be sure your transformation point is at the bottom of the handle. To be sure, just activate Free 

Transform (Q) and move the white dot to the corner if it’s not already there. It will rotate from this axis. 
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96. Insert a keyframe (F6) at frame 35 on the swatter layer. Then, in that frame, rotate (Q) the flyswatter up. 

 

97. Insert a Classic Tween (older versions, Motion Tween) between those frames (right click up there on the Timeline). 

98. Insert a frame (F5) at frame 125 on all layers. Test Scene. It should “swat” the fly. Make any changes necessary (placement 

of the bee, for example). Save! 

99. Create two more layers for sounds as shown below (lock other layers). On the buzz layer, pull in the beebuzz sound. For the 

ouch layer, insert a blank keyframe (F6) at 30 and drag in the bonk sound at frame 30 (Import to Library first). 

 

100. Test and Save! 

 

That was a pretty good review! How did you do? 

 

More on Text 

One big change in the newest version is the use of TLF text in Flash files. This will sometimes cause errors, so for beginners, it’s 

probably best to set text to “Classic Text” and then Static Text as shown below: 

 TLF text is pretty neat. You can use special “classes” with ActionScript to 

animate this special kind of text. You are also given the really super long character Properties (shown earlier) where you can change 

lots of things. However, if you are starting out and not utilizing any of those features, Classic/Static Text is all that is necessary to just 

use and tween basic text. Before we move on, click the text tool and set this as shown above. 
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Your Turn—Part 14 

101. Create a new layer called beehave. Lock remaining layers. 

102. Insert a blank keyframe on frame 35.  

103. Use the Text tool and a clear font, size 96, in the gold color from the center of the daisy (use eyedropper). Type the word 

BEEhave!  Set the text properties to be centered: 

  

104. Switch to the Selection tool (black arrow) and click the text box. Then, convert the text to a movie clip symbol—F8. Call it 

text. 

105. Position the text centered on the stage using the Align panel. Window> Align. Set as follows: 

  

Be sure to check “Align to Stage” before pressing the two buttons! 

106. Use the Quick Transform handles (Q) and resize the symbol as shown: 

107. We don’t want this text to begin on screen, so let’s move the keyframe. 

To do that, click on the keyframe 1 and let go. Then, click and don’t let 

go and drag to frame 30. Then, let go. 
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108. Now, insert keyframes at 35, 40, and 45 (F6).  

109. Make the following changes to each of those keyframes: 

frame 30—click the text and resize using the handles (Q). Then, in the Properties panel, set Color Effect to Alpha of 0, 

which is invisible. 

  

frame 35—leave as is (big) 

frame 40—resize and place in top left corner 

 

frame 45—resize and angel in corner 

 

110. Now, between each of those keyframes, insert Classic Tweens by right clicking between keyframes (old versions, Motion 

Tween). 

111. One little change. Between frames 40 and 45, let’s add a spin. That can be done by clicking in the purple tween area and 

setting Rotate in the Properties panel to CW (Clockwise) and 1 spin. 
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112. Press Enter to preview or Test Scene. Save! 

113. Finally, create one more layer called haha. Import the sound behave.wav to the Library. Insert a blank keyframe at frame 

40 and drag the sound onto the layer. 

 

114. Save and test one more time! 

115. It’s pretty loud. Actually, if you look at the waveform closely, the audio “clips”. So, fix that by lowering the levels. Click in the 

behave/haha sound and click the pencil (or Edit in previous versions) in the Properties panel to edit the sound. Bring the 

top lines down as shown to lower the volume: (use the magnifying glasses to zoom out) 

 

If you are satisfied with the volume (press the play button to preview), we’re all done with this scene.  

116. Switch to the final replay scene. 
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Flash Buttons 

Unlike other symbols that have timelines, buttons have four button states instead. They are: 

Up� The appearance of the button when the pointer is not over it.  

Over� The appearance of the button when you place the pointer over it.  

Down� The appearance of the button when you click on it.  

Hit� Defines the area that will respond to a click of the mouse.  

You can still drag sounds into the various button states and you can drag symbols into the button as well. As a matter of fact, it’s a 

good idea to create the main part of the button as a symbol first and then add the text on a separate layer within the button. Let’s 

make that happen. 

Your Turn—Part 15 

117. Create a new movie clip symbol (Insert>New Symbol) called buttonbox. Inside, draw a shape for the button with a  stroke 

and fill of your choice. To give the corners a rounded look, set the Rectangle Options in the Properties panel before you 

draw: 

   it’s a button in older versions�  

118. After drawing the shape, double click it with the Selection tool to select it. Then, center align it to the Stage (very important 

for all buttons!) using the Window>Align panel (center horizontally and vertically and set to align to stage). 

   

It will be centered on the registration point. 

119. Return to the Scene. 

120. Next, create a new symbol (Insert>New Symbol) that is a button type called replaybutton. 

  

121. In the UP frame, drag the buttonbox movie clip in. Center it using the Align panel. 
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122. Press F6 in the OVER frame to copy the symbol to that frame and make it ready for change. We will add a Filter to this 

frame so that when you are pointing to it, the button glows. To do this, click the Filter drop down in the Properties panel, 

press the first button and choose Glow, and set the color and blur values.  

  

NOTE: In older versions, this is in a panel beside the Properties panel 

 

123. Now, label that layer box and lock it. 

124. Create three new layers inside the button—text, sound, and bee.  

125. On the bee layer, insert a keyframe (F6) in the OVER state. Then, 

bring in two copies of your bee movie clip and size/position as 

shown, leaving room for the text: 

 

 

126. On the text layer on the UP state, create the words REPLAY in a font and style of your choice. 

   

127. Import the sound file to the Library called groovy. Insert a blank keyframe (F6) on the sound layer in the OVER state. Then, 

drag the sound in.  

NOTE: Flash has several filters you can 

apply to movie clips—blur, glow, bevel, 

and shadow. You can add more than one 

filter to a symbol. 
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128. Finally, press F5 to insert a frame on all HIT states. 

 

129. Save and return to the scene. 

130. Create two layers—actions and button. Drag the replaybutton to the Stage on the appropriate layer and then lock it.  

  

131. If you save and test, everything should work except 1) Your sound doesn’t play and 2) Your button doesn’t go anywhere. 

132. Since this is a button, the Sync for the sound must be set to Event. Clicking a button is considered an “event” in Flash. So, 

inside the button, click on the waveform and set the Sync to Event in the Properties panel.  

 

133. Return to the scene. 

134. Press Control+Enter to test the entire movie. You will notice that the movie does not stop to give us the opportunity to 

press the button in the last scene. Also, we haven’t told the button where to go either. That’s up next. 
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Actions 

The power in Flash is the use of ActionScript. It’s a programming language used to tell Flash objects what to do. It can also control 

the Timeline.  

To add Actions, you must use the Actions panel, accessed by pressing F9. Probably the most common action is the stop action: 

 

To attach actions to objects/movie clips/buttons, you must give the item 

an instance name. This is done in the Properties panel when you are 

clicked on the object.  

You can tell if ActionScript is in a scene or not by the presence of a little 

lower case “a” on the timeline: 

 

 

Your Turn—Part 16 

135. We should be at the main Timeline in the replay scene. The button layer should be locked. Click on the actions layer. Open 

the Actions panel (F9). 

 

136. Now, you must type in the code to control the button. First, we have to “give the button” an ActionScript name. It’s not the 

same as its Library name. So, we’ll make something up… just call it replay_btn in the code below. Depending on your 

version of Flash and ActionScript, the code varies. 
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Flash CS4/CS5 or any version using ActionScript 3.0, here’s the code: 

 

Flash 8 or any version using ActionScript 2.0, here’s the code: (be sure Script Assist is turned off) 

 

137. Now, it won’t work yet. We have to actually assign that instance name we mentioned (replay_btn) to an object (in this 

case, our button). So, click on the button (unlock first). In the Properties panel, type in replay_btn as the Instance name in 

the white box. 

  

138. Now, if there are no errors (cross your fingers), your project should stop and the button should function. Press 

Control+Enter to check it out. 

139. That’s it! Save and close! 

 

A Few Notes 

Every time you Test Scene or Test Movie, you actually create a Flash SWF file, the default “publish” format. These are the types of 

files that can be embedded onto webpages or PowerPoint files. If you look in your folder, you will see several: 

You can also specify the export format under File>Publish Settings. 
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Inserting SWF files in PowerPoint 

Ensure the Flash Player is installed on your computer, and then follow the steps 

below:  

 

 Click Microsoft Office Button on the top left corner, click “PowerPoint Options” at 

the bottom of the panel > go to the “PowerPoint Options” window > click “Popular” 

on the left column > select “Show Developer tab in the Ribbon” on the right 

column > click “OK” at the bottom 

   

On the “Developer” tab > go to “Controls” group > Click the icon of hammer and nail for “More Controls” > go to the “More 

Controls” window 

  

  

On the “More Controls” window > select “Shockwave Flash Object” in the list > click “OK” at the bottom > use your pointer to drag 

on the slide to draw and resize the control 

                           

 Right click the control you drew > click “Properties” in the right-click menu > go to the “Properties” window 
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 On the alphabetic tab > click the “Movie” property > type the full drive path in the value column (the blank cell next to Movie), 

including the file name (e.g. C:\Documents and Settings\tskinner\Desktop\FlashWkshop\Card.swf) or URL (including http://). 

  
NOTE: If you save the PowerPoint first, you can just type the filename with the .swf extension in the Movie box and it will work. If saving to show on 

a different station, just be sure the presentation and the SWF files are in the same folder and do not add the path. The source file must be available. 

You cannot run the PowerPoint without the SWF file (the animation will not play). 

 

To make the Flash play automatically when the slide is displayed, set the “Playing” property to “True“; To embed the Flash into 

PowerPoint, set “Embed Movie” property to “True.” 

  

Finally close the “Properties” box and save your presentation. View the slideshow (F5) and all should work. Sounds should work and 

buttons will be clickable, just as if it was on a webpage. Pretty nifty! 

 

Animated GIFs in Flash 

Flash can be used to create GIF animations and not just SWF embeddable files. GIF animations can be placed directly on a webpage 

or in a PowerPoint file and will animate when previewed on the website or presentation. Basic animations can be created in Flash 

and published as GIF files for these purposes.  

Reasons not to use SWF: 

-slows page load 

-Flash plug-in is required to view 

 

Reasons to use SWF: 

-if you need something interactive 

-if you need audio 

-if the animation is complex 

 

If an animated GIF will do the job, consider publishing to this format.  
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Your Turn—Animated GIF in Flash 

1. This time, we’ll create a new Flash file to be used on a PowerPoint that is a simple animation. We will then export this 

animation in animated GIF format. So, start a new Flash file (AS3 is fine). Save as question. 

2. In the Properties panel, set the frames per second to 24, size to 200px by 200px and a background of black. 

 

3. Next, to make this go faster, let’s import a graphic rather than draw our own. Import the file (File>Import>Import to 

Library) called boy_confused.gif to the Library. Press F11 if your Library isn’t visible. 

4. To make this editable, pull the clipart over to the Stage and Trace Bitmap (Modify>Bitmap>Trace Bitmap) with the 

following settings: 

 Then, remove the white background (click with black arrow and delete). 

5. Select all (Control+A) and press Q to activate the Transform controls. Size and position as follows: 

 

6. Now, select ONLY the red question mark (just draw around it) and convert that to a movie clip symbol (F8) called 

question. Double click it to go into symbol editing mode. 

7. Insert a keyframe (F6) at frame 3 and rotate a little to the left; insert a keyframe at frame 5 and rotate back to the 

middle; insert a keyframe at frame 7 and rotate to the right. 

 

8. Then, return to the Scene.  

9. Zoom up to 400% and we’re going to just make him blink on the main timeline. Simply insert a keyframe at 30 (F6). 
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10. Now, use the eyedropper to sample his flesh color and use a paintbrush to paint away as shown: 

 

11. If you look at it now, it looks strange because the blink is too fast. So, to make the eye stay closed longer, just insert a 

frame (F5) at frame 34 or so and the animation will be smoother. 

12. Save! Control+Enter to test the movie! 

13. Since this is really not a “movie” so much as it is an animation, we need to prepare it to be used on a presentation or 

website. Click on File>Publish Settings: 

 Uncheck everything and select GIF image. 

14. Then, click the GIF tab and be sure to set the playback to be Animated and the Transparency to Transparent. 

 

15. Click PUBLISH and it will save a copy of the animated gif (question.gif) to the project folder. 

16. Now, it is ready to insert onto a webpage or a PowerPoint. From PowerPoint, just simply insert as you would any other 

graphic file—Insert tab>Picture and browse for the file. You will notice the background is transparent (we just used 

black to be sure we didn’t have any white pieces left over from the beginning background…it’s a good trick) and when 

you play the slideshow, it animates. 
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Masks 

A more “advanced” Flash technique is using masking. Masking means that you “hide” part of the Stage or part of an object on the 

stage, much like you “hide” part of your face when wearing a Halloween mask. An example of a web banner that uses masking is 

located here-- http://www.simplygraphix.com/portfolio_webbanners.html  (check out the first USA Green Card example) 

Masks are really quite easy to create. You simply put the “mask area” (in the form of a shape or you can paint brush the area) on a 

higher layer than the object you wish to mask, right click that layer, and set it to Mask. That’s really all there is to it! 

Your Turn—Web Banner with Flash 

1. We’re going to create a quick banner for a website. First, let’s create a tall banner. Standard web banner sizes are:   

(from http://www.designerstoolbox.com/designresources/banners/) 

 

So, create a new Flash file (AS3) with a width of 120 and height of 600 (a “skyscraper” format). Or, you can create a new file 

from a Flash template and select that from the list: 

 

2. Set the background of the Stage to black (Properties panel).   

3. Then, draw a green rectangle (NO STROKE). Double click the rectangle and set the 

size to 115 W by 595 H (Properties panel). Align to the Stage with the Align panel 

(Window> Align). 

4. Dress up the rectangle however you’d like (shapes, lines, etc.) and add your name 

or a company name. 
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5. The images we are using are from Carlos Porto’s portfolio and free to use with 

acknowledgment, so here’s his address: 

http://www.freedigitalphotos.net/images/view_photog.php?photogid=345 

To save time, I have already put a few of these photos together in Photoshop. The file is called 

food.jpg and should be imported to the Library in Flash (File>Import>Import to Library). 

6. Now, we are going to create scrolling food. However, to add a tween to the food, the food 

group has to be a symbol. So, create a new movie clip symbol called doublefood (Insert>New 

Symbol) and drag the food.jpg file over into the symbol. Then, drag a second copy and put it 

right next to it so that there is no seam: 

 

7. Return to the Stage. 

8. Now, we have to create the scrolling food using that doublefood symbol. So, create another 

new movie clip symbol (Insert>New Symbol) and name it scrollfood. Drag the doublefood 

symbol onto the Stage of this symbol.  

9. Now, we have to line up the apples so that they are in the same spot (the first set and the last 

set) when they tween. Otherwise, it will jump a little at the end of the animation. So, turn on 

the Ruler (View>Rulers) and then drag a guide out from the left vertical ruler and line it up 

with the far right edge of the first set of apples. 

 

10. Now, insert a keyframe at 50 (F6). Hold Shift and drag the banner left until the second set of 

apples lines up on that guide. Then, drag the playhead just to make sure it doesn’t jump. 

11. Now, insert a Classic Tween (Motion Tween in older versions) between those two frames (right click between them on the 

Timeline). 

12. Finally, so that one frame of green apples doesn’t repeat when it replays, just 

insert a keyframe (F6) in frame 49; then delete (right click, Remove Frame) 

frame 50. 

13. Return to the Scene. Make a new layer called photos. Drag scrollfood out and 

position as shown at right� 

14. Test Scene. It should scroll nicely. However, we want a “window” (or mask, as 

they are called) to show the pictures through so they don’t take over the 

whole top of the banner. 
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15. Create a new layer on top and call it window. Lock the rest of the layers. 

 

16. Now, draw a rectangle (color does not matter) over the area where you want the window: 

 

17. The last step is super easy. To activate the “window” (mask), simply right click the 

window layer and select Mask from the menu. That’s really it. 

 Notice the appearance of the mask layer. And, it locked the layers. You can still 

edit them if you unlock, but for the mask to work, you do have to lock them back 

before testing the scene or publishing the animation. 

18. Test Scene. It should work well now. If you wanted to go a step further, you could add a text layer 

and animate some text, add a new layer and put a border around the masked area, or whatever you 

desire. But, that’s the basic setup for creating a scrolling image and a mask in Flash. 

19. To use on a website, either publish as an animated GIF or as a SWF and follow the instructions in 

your program for inserting the appropriate file type. 

20. Save and you’re done! 
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NOTES/ACKNOWLEDGEMENTS/RESOURCES USED 

Adobe Flash for Beginners—Graphics & Animation 

http://www.bill-morrison.com/class/adobe-flash/1-graphics-animation/index.html 

How to draw a cartoon bee 

http://www.how-to-draw-funny-cartoons.com/cartoon-bee.html 

Beehive 

http://www.daniellesplace.com/Images4/beehive72.gif  

Buzzing Sound 

http://resources.bravenet.com/audio_clips/sound_effects/animal_-_bee_or_fly_buzz/listen/  

Fly Swatter  

http://www1.free-clipart.net/gallery2/clipart/Household/Miscellaneous/Fly_Swatter.jpg  

Austin Powers clip “Oh behave” 

http://resources.bravenet.com/audio_clips/movies_tv/austin_powers_-_oh_behave_yeah_yeah_baby/listen/  

Oh Groovy Baby clip 

http://www.moviesounds.com/austin.html  

Flower Cliparts 

http://www.clipartspace.com/flower-clipart.htm 

Bonk Sound 

http://www.grsites.com/archive/sounds/view/1618/ 

Confused Boy 

http://www.hasslefreeclipart.com/clipart_school/boy_confused.html 
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ActionScript Notes 

--Link to URLs 

AS2 

monkey_btn.onRelease = function() { 

    getURL(“http://www.flashthusiast.com”); 

}; 

 

AS3 

monkey_btn.addEventListener(MouseEvent.MOUSE_DOWN, mouseDownHandler); 

function mouseDownHandler(event:MouseEvent):void { 

    navigateToURL(new URLRequest(“http://www.flashthusiast.com/)); 

} 

 

--Link to Scenes/Frames 

AS2 

mbutton1.onRelease = function() { 

 gotoAndStop(2, “monkeyScene”); 

}; 

 

AS3 

stop(); 

  

mbutton1.addEventListener(MouseEvent.MOUSE_DOWN, mouseHandler1); 

  

function mouseHandler1(event:MouseEvent):void { 

  

gotoAndStop(2, “monkeyScene”); 

  

} 

 

--Sound (play throughout, start automatically) 

AS3 

var music:Sound = new Sound(new URLRequest(“song.mp3”)); 

music.play(); 

 

 


